From AMule Project FAQ
Revision as of 02:26, 27 April 2010 by DavilinkIcefire (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

English | Deutsch | Español | Italiano


Here is the list of requirements be able to run all of aMule package's applications (the requisites for compiling aMule are mentioned in the compilation articles).

Requirements for specific aMule applications (amuled, amuleweb, wxcas, ...) are listed in the appropriate application article.


  • An aMule-compatible platform. Though it supports a wide variety of platforms, some few rare ones are still not (officially) supported.
  • A keyboard, a mouse and a screen are strongly recommended for obvious reasons. Though they might not be needed depending on the aMule application you want to run.



  • An aMule-compatible operating system is required
  • The standard C and C++ libraries
  • wxWidgets 2.8.7 or higher. Command line applications will do with just wxBase. GUI applications will require their wxwidgets taste (wxGTK, wxMSW, wxMac, etc) depending on the Operating System you are running on (note that wxbase is integrated into all wx GUI tastes). wxWidgets 2.8.7 is mandatory if you want support.
  • zlib library
  • libcrypto++ library
  • bison is required to compile aMule


  • GetText is not absolutely required, but very strongly if you want to use any of aMule's translations
  • libpng is recommended when using amuleweb to be able to generate progress bar images
  • libgd is recommended when using cas to be able to generate images
  • flex might be needed to generate some files, but maybe not.
  • Perl and XChat are required to run some tools in the aMule package